[LinuxBIOS] VIA K8T890+VT8237 - update of the status

Rudolf Marek r.marek at assembler.cz
Wed Aug 8 22:29:59 CEST 2007

Hash: SHA1

Hi Corey,

> Both of these should be solved with ACPI tables, one of the Epia-M pages
> in the wiki has some good info on using iasl. Also make sure
> HAVE_HARD_RESET = 0 in mainboard Options.lb

Ok have there =1 will try it.

>> I may write more about my issues if only someone is willing to help ;)
>> I can put
>> my code online somewhere. Maybe it would be good to check it in even
>> if the code
>>  for NB is a bit of mess.
> That's your call, but I doubt it could hurt. First check that your code
> is at least fairly clean and follows the coding guidelines (check the
> wiki). You might also want to check with Via and make sure that's okay,
> I don't know what your status is regarding NDAs. If you don't have one
> at all, you should be fine.

I have NDA. I cant just publish the specs in unaltered form. I must publish my
code under GPL, comments in code are OK. I cannot create any other document
except the source code (which describes VIA stuff).

>> USB/sound/SATA/IDE/PCIe/Network/Serial/Graphics/APIC works do far...
> USB works? Have you made any fixes or are you using the code I sent you
> as-is? And for graphics, are you using onboard or a seperate card?

I think I sent you some code already too. It is ATI Radeon X300SE (rv370) in
PCIe slot. So separate.

> And on 2, it actually tries to reboot but stops after printing the inital banner? No attempt at ram init or anything? It might be that yhlu has set up the k8 to not re-do ram init after a reboot, but I'm not sure.

Yes just only one line...

Well lets try with = 0 first.


Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the coreboot mailing list