[LinuxBIOS] Booting Windows - LinuxBIOS

Augusto Pedroza augusto.pedroza at gmail.com
Fri Jul 13 16:09:43 CEST 2007

For some reason  BX_ELTORITO_BOOT was disabled when using ADLO. Does anyone
know why? At this point I need qmeu + linuxbios_+ ADLO to be able to install
windwos in a qemu image from the installation CD.

file: rombios.c

Where can I find what are the current cmos settings?
qemu + bochsbios is able to boot from the CD because
bootseq receives 3 on the following piece of code. When
using linuxBIOS, bootseq receives 2.

 // if BX_ELTORITO_BOOT is not defined, old behavior
  //   check bit 5 in CMOS reg 0x2d.  load either 0x00 or 0x80 into DL
  //   in preparation for the intial INT 13h (0=floppy A:, 0x80=C:)
  //     0: system boot sequence, first drive C: then A:
  //     1: system boot sequence, first drive A: then C:
  // else BX_ELTORITO_BOOT is defined
  //   CMOS regs 0x3D and 0x38 contain the boot sequence:
  //     CMOS reg 0x3D & 0x0f : 1st boot device
  //     CMOS reg 0x3D & 0xf0 : 2nd boot device
  //     CMOS reg 0x38 & 0xf0 : 3rd boot device
  //   boot device codes:
  //     0x00 : not defined
  //     0x01 : first floppy
  //     0x02 : first harddrive
  //     0x03 : first cdrom
  //     else : boot failure

  bootseq|=((inb_cmos(0x38) & 0xf0) << 4);

Looks like I need to change some CMOS settings.

Augusto Pedroza
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070713/be98fe38/attachment.html>

More information about the coreboot mailing list