[LinuxBIOS] [PATCH] Add initial serial output for Via vt82c686

Corey Osgood corey_osgood at verizon.net
Sat Mar 17 05:01:28 CET 2007

Uwe Hermann wrote:
> Yay, progress.
> With the attached patch I get serial output on my board on serial port 1.
> I didn't try COM2, yet.
> Not quite sure what the initial problem was, but the current code works
> for me. Corey, can you please verify whether it still works on your board?
> I made some changes here and there (mostly cosmetic), but maybe I broke
> some parts of the code, so please verify on your hardware...
> If it works (and if you don't spot further problems in the code) I'd say this
> can be committed. Please send an Acked-by if the code looks good to you.
Awesome! I was starting to get concerned that I'd done something that 
only worked on my board. I've got no problem with your changes (although 
I can't _find_ an io base), and the code works fine on my board.

Acked-by: Corey Osgood <corey_osgood at verizon.net>

One thing though:
> +	// sbdev = PCI_DEV(0, 7, 0);
> +	if (sbdev == PCI_DEV_INVALID) {
> +		/* Serial output is not yet working at this point, but
> +		 * die() emits the POST code 0xff and halts the CPU, too. */
> +		die("Southbridge not found.\r\n");
> +	}
die() in console/console.c does send a post code, but if I try to use 
it, gcc gives an error about function type pointers that I haven't been 
able to track down the cause of. The die() src/arch/i386/lib/console.c 
doesn't send a post code, and that's the one I'm currently using, since 
that's what whichever motherboard I based my code on was using. So, 
either that console.c should get fixed up, or I should figure out why I 
can't use the other one (or even both).


More information about the coreboot mailing list