[coreboot] qemu ethernet fix for v3 (port from v2)

Cristi Magherusan Cristi.Magherusan at net.utcluj.ro
Wed Apr 22 20:10:40 CEST 2009

On Wed, 2009-04-22 at 08:42 -0700, ron minnich wrote:
> 2009/4/21 Cristi Magherusan <Cristi.Magherusan at net.utcluj.ro>:
> > Hello,
> >
> > I tried to port Ron's fix to v3, and now it seems ifconfig eth0 up
> > works, the IP address can be manually set, but DHCP fails and ping to
> > qemu's default gateway fails causing kernel's watchdog timer to expire.
> >
> I would not commit a patch that is known not to work. It just makes
> things worse.
I didn't want to get it committed, but merely wanted to make a starting
point so that someone more experienced could help me to get it work on

> If you are seeing pings fail, it means that the interrupt is not being
> seen by the kernel, or is being interpreted by the kernel as being for
> some other device.

> So, this is a start, but it may be the wrong direction.
> ron
Any hints on what can I do to make it work?

FWIW, In v2, eth0 gets assigned 5'th IRQ, as I can see
from /proc/interrupts, while in v3 /proc/interrupts shows nothing about


Ing. Cristi Măgherușan, System/Network Engineer
Technical University of Cluj-Napoca, Romania
http://cc.utcluj.ro  +40264 401247
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090422/8e218ad6/attachment.sig>

More information about the coreboot mailing list