[coreboot] SeaBIOS on DBE63 not functional

Kevin O'Connor kevin at koconnor.net
Wed Jan 28 02:02:52 CET 2009


On Tue, Jan 27, 2009 at 08:28:13PM +0200, Mart Raudsepp wrote:
> I haven't been able to really play with SeaBIOS before, as it can't boot
> from NAND flash that is on DBE61 and DBE62, but now with the DBE63
> prototype on my table I can boot from IDE CompactFlash.
> On a slightly related note, does SeaBIOS really need to do the
> bootloader job - could I have it just provide the 16bit services or do
> we need to implement a geode NAND flash driver in it to have it work for
> those devces?

You might want to see if there is a NAND flash option rom out there
somewhere.  If it exists, it could add "drop in" support for booting
from flash.

Otherwise, there have been two proposals for this - the first is to
have SeaBIOS return to coreboot instead of "booting" the system.  Then
coreboot could be extended to launch the real boot program (eg, grub)
from flash.  The other proposal is to implement LAR support in SeaBIOS
- then seabios could pull a boot image (eg, grub) from the lar and
launch it.  I've been a proponent of the second proposal.

> The log output at default loglevel of 1 is attached. At higher log
> levels the last dump seems to come from a different place. Should I
> gather such logs with a larger loglevel or does this say something
> revealing already? Anything else I can provide here?

Those messages aren't reporting a problem - I see them on my epia-cn
and on qemu.  You'll need to increase the debugging level to see if
something else is seen before a failure.

BTW, does the DBE63 implement all the legacy hardware (like ioport
access to timers, cmos, etc.)?


More information about the coreboot mailing list